ALERT: Priva cloud incident occurred

Incident Report for Priva

Identified

Most major issues have now been resolved. The application is functioning normally again for the majority of our customers.
However, some users may still experience minor issues or bugs. Our team is continuing to address these on a case-by-case basis.

Thank you for your patience and understanding while we complete this work.
Posted Oct 27, 2025 - 10:30 CET

Investigating

We are currently experiencing issues with our analytics service. You may have noticed this issue yourself if reports were not generated correctly or appeared incomplete.

Our Technical Team is working hard to resolve this problem – we apologize for the inconvenience. We aim to restore normal service as soon as possible. Thank you for your patience.

While this issue lasts, you may be unable to access analytics data, or the results may be incorrect or delayed.
Posted Oct 09, 2025 - 13:40 CEST
This incident affects: Priva Analytics.